Browse Help Topics & FAQs

Android Devices Compatible with Yoco

We support most Android devices on the latest version of the Yoco app (1.0.8 and higher). The minimum requirements are as follows:

* Android 2.3.6 (Gingerbread) and above
* 800x480 screen resolution and higher
* 3G/LTE internet connectivity
* GPS
* Bluetooth connectivity
* 512MB RAM or more

For the best experience we recommend a phone/tablet with the following specs:

* Android 4 and above
* 1GB RAM
* Quad core CPU

We have successfully tested the following Android phones:

Vodafone Smart 4

Vodafone Smart 6

Acer Z500

HTC Desire HD

Sony Xperia E1

Sony Xperia Z2

ZTE Grand X2

HTC One

Huawei Y220

Huawei Y300

Huawei Ascend G525

LG G3

LG G Flex

Ruggear RG500

Samsung Galaxy Note 4

Samsung Galaxy Note 3

Samsung Galaxy S6 Edge

Samsung Galaxy S6

Samsung Galaxy S5

Samsung Galaxy S5 Mini

Samsung Galaxy S4

Samsung Galaxy S4 Mini

Samsung Galaxy S3

Samsung Galaxy Trend Plus

Samsung Galaxy A3

Samsung Galaxy A5

Samsung Galaxy Young 2

Samsung Galaxy Trend Neo

We have also successfully tested the following Android tablets:

Samsung Note 10.1
Samsung Galaxy Tab E
Asus Google Nexus 7
Nivia Shield
Dell Venue 7
MTN 8978P Steppa Tablet

Please note: If the app is not available for download in the Google Play Store, then it has not met the minimum requirements for the app. 

If you are unsure if your phone is compatible with the Yoco solution please download the following Spec Device app: https://play.google.com/store/apps/details?id=com.specdevice 

Navigate to 'My Spec Link' and email to support@yoco.co.za; we will then be able to confirm if your device is compatible. 

 

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk